View Single Post
Old 03-20-2016, 12:20 PM   #1
Junior Member
Join Date: Mar 2016
Location: Des Moines, IA USA
Posts: 1
Angry Displaylink caused Win 8.1-64 to stop recognizing my RAID tower and 1 of 2 printers.

Windows automatically installed DisplayLink software during an Update. My brand new computer was recognizing my Etekcity LapDock hub, but was showing the indicator for the need to update drivers for it. My RAID hard driver tower and two Epson all-in-one printers are routed thru this hub, and were working as they were supposed to.

I had to order and install a new WiFi card in for this computer to gain Internet access or use in my home, which allowed me a couple of days to explore this new computer before it updated. The hardware all worked fine. (My home has a single Internet access point, with computers connected by WiFi to it.)

After this computer gained access to the Internet, it went through a serious update of Windows 8.1 – 64 and the graphics drivers. During this update, It showed Displaylink being installed to control multiple monitors. I do have multiple monitors, but only one monitor was connected at this time.

Anyway, I allowed the Displaylink to continue to install. But problems started right after the next re-boot. My RAID tower became unrecognized, along with my more advanced of the two Epson printers.

Removing the Etekcity LapDock hub and replacing it with a 4 or 5 year old Toshiba Hub caused the software to reclassify the hardware with the same results the RAID tower or the newer printer. I have verified with a different computer that the RAID Tower and printer are functioning properly.

That leaves your software as the problem. Disabling your software from starting with Windows does not seem to help. I tried that.

So how can I get my equipment to start working properly again, along with getting your software off of my computer?


Last edited by Lloyd; 03-20-2016 at 12:25 PM.
Lloyd is offline   Reply With Quote