View Single Post
Old 10-27-2017, 09:37 AM   #10
Junior Member
Join Date: Aug 2017
Posts: 9
Default A fix that might have something to do with this


After I upgraded to 17.10, my mouse is a bit sluggish, so I have searched around for a solution to this. I found a reddit post:

There is a reported problem with the kernel 4.13 and some Intel graphics. My computer was crashing constantly and I was blaming Plasma, but it was the parameter intel_iommu that has been enabled by default in 4.13. Try to set the kernel parameter intel_iommu=off and hopefully it will help.

This was verry interesting regarding my problem with the external monitors that is being disabled.

I now have kernel version 4.13, so I turned intel_iommu to off, two days ago. I have manged to force the problem only one time after this. The problem do not appear while I sit at the computer, anymore. I have noticed that the external monitores is turned off, a couple of times, if I have left the machine for a couple of hours.

I do still have a sluggish mouse, and the CPU is going through the roof when the screensaver has been running for a couple of minutes... But I think this is related to the upgrade from 17.04 to 17.10.

I'm immensely interested if anyone else with this problem do see effect by changing this option.

To change it if you are on ubuntu/debian, edit your /etc/default/grub, and add intel_iommu=off to the GRUB_CMDLINE_LINUX_DEFAULT line. Then update grub by running update-grub2.

If you try this, please report back if this has helped you, and if the problem has been just reduced, or completely fixed....

-- Edited 2. nov., after a week, with this fix.

This is strange. Once again I see improvement right after the change has been done, but after a day or two the error is back. And I'm back to square one.....

Last edited by FrodeJemtland; 11-02-2017 at 08:37 AM.
FrodeJemtland is offline   Reply With Quote