View Single Post
Old 01-25-2021, 12:12 PM   #2
rboerner
Super Moderator
 
Join Date: Jan 2015
Posts: 67
Default

Quote:
Originally Posted by HolographicDoc View Post
I'm trying to connect two displays, but when I run Displaylink, it always says the connection status is "No monitor detected"

I'm using a 2020 MacBook Pro on M1 chip, Big Sur 11.1, and a startech USB-C to 2x displayport adapter. I've installed DisplayLink Manager Graphics Connectivity 1.2. Screen recording is enabled for Displaylink. This is my first time using this software (i.e. it's not like it worked previously for me)

I am able to plug one of my DP cables into the Startech adapter and successfully extend my screen to one monitor. When I plug the second cable in, only one monitor works and it appears blurred (as though two images are overlaid on one another). Regardless of the connection, Displaylink always says "no monitor detected".

I've tried many re-installs, restarts, without success. Perhaps relevant, in Software > Extensions there is no DisplayLinkDriver.kext at all when I install the most recent version (when I tried to install a legacy version, this extension became present but was not loaded - even though I gave appropriate permissions when I tried that).
I can't be sure since you don't mention the specific model number of the StarTech adapter you are using, however based on your description it doesn't sound like the adapter you have is using DisplayLink technology.

If pressed to guess, the StarTech adapter you are using is based on DisplayPort MST hub technology, which is not supported on Macs.
rboerner is offline   Reply With Quote