View Single Post
Old 09-14-2021, 11:05 PM   #1
Junior Member
Join Date: Sep 2021
Posts: 1
Question Problems With ViewSonic VX2452MH On Linux

I got myself a new thinkpad P1 laptop running Ubuntu 20.04 and I am setting up an old Thinkpad USB-C to USB-A Hybrid Dock to work with it.

On this new laptop I have installed the latest display link drivers (5.4.1), I have installed the latest firmware on the dock. If I connect the dock to my windows machine, the two connected ViewSonic monitors work without issue.

However, I have a weird issue when I try and connect the dock to my Linux machine, I see only one of the two monitors. Both are the same model (VX2452MH) but one was made in 2018 and one was made in 2015 (the 2015 is the one that can't be seen). I have tried multiple things:

(1) I switch ports, still the same issue
(2) I switch HDMI cables - same issue
(3) I only connect the bad monitor - still not seen
(4) I connect the 2015 monitor directly to the HDMI port on my Linux laptop and it works!
(5) I have used the laptop with both hybrid graphics driver or discrete only - still the same
(6) I have switched from the nouveau driver to the proprietary NVIDIA driver - still the same.

Am I missing something obvious? I am a little stumped with this.

gcollins is offline   Reply With Quote