View Single Post
Old 09-18-2020, 12:04 AM   #1
Junior Member
Join Date: Sep 2020
Posts: 8
Unhappy external monitor not detected in Ubuntu/20.04 with DL-59xx chipset

I am running generic Ubuntu/20.04 with generic kernel.

I have two external monitors attached to my laptop. One attached to HDMI, another one attached to my displaylink hub powered by a newer DL-5910 chip (Dell*D3100) via usb/3.

The laptop has a builtin Intel GPU and a Nvidia gpu, which I use nouveau driver for it.

Installation process was smooth, and after reboot it seems that the displaylink driver has installed successfully.

However, the external monitor attached to the usb hub is simply not working.

I almost want to say it is not detected, but it's not that simple.

During the login process, gdm3 seems to know that I have two external monitors thus all monitor painted dark purple.

Once I log in, though, the external monitor attached to usb simply doesn't work.

I thought the external monitor simply wasn't detected... but when I run the following, it shows that the monitor was attached

$ ls /sys/class/drm/*/status | xargs -I {} -i bash -c "echo -n {}: ; cat {}"
and dmesg also had one line which indicated that displaylink found the attached monitor:

[ 27.803323] evdi: [D] evdi_painter_mode_changed_notify:701 (dev=0) Notifying mode changed: 1280x1024@60; bpp 32;
(my external monitor is an old Sony which has 1280x1024 resolution. I connected it via DVI port).

I also manually edited the 20-displaylink.conf file in /etc/X11/xorg.conf.d
Section "OutputClass"
Identifier "DisplayLink"
MatchDriver "evdi"
Driver "modesetting"
Option "AccelMethod" "none"

Section "Device"
Identifier "DisplayLink"
Driver "modesetting"
Option "PageFlip" "false"
I also patched the x server, gotten the deb package from this website

But still, the external monitor simply not detected by xrandr

In fact, when run xrandr --listproviders, displaylink gpu is not detected:
Providers: number : 2
Provider 0: id: 0x46 cap: 0x9, Source Output, Sink Offload crtcs: 4 outputs: 3 associated providers: 1 name:Intel
Provider 1: id: 0xa9 cap: 0x4, Source Offload crtcs: 0 outputs: 0 associated providers: 1 name:nouveau
yet, the driver seems to loaded:
$ lsmod|grep -i evdi
evdi 53248 4
drm_kms_helper 184320 3 evdi,i915,nouveau
syscopyarea 16384 2 drm_kms_helper,evdi
sysfillrect 16384 2 drm_kms_helper,evdi
sysimgblt 16384 2 drm_kms_helper,evdi
drm 491520 13 drm_kms_helper,evdi,i915,ttm,nouveau

Any idea/hint/pointer on how to solve this problem?

thanks in advance

ps. displaylink-debian installation script yield the same result.
Attached Files
File Type: zip (813.6 KB, 0 views)
kngharv is offline   Reply With Quote