View Single Post
Old 12-09-2016, 01:52 PM   #26
Mahdi2016
Junior Member
 
Join Date: Oct 2016
Posts: 20
Default

Hi Michal,

I use ubuntu mate (16.04) for my RaspberryPi 2.
The system is up to date (apt update, apt upgrade). After trying 'sudo BRANCH=next rpi-update' and 'sudo rpi-source' the current kernel and sources was installed.
I also try to add the following lines into '/boot/config.txt:
Code:
dtoverlay=vc4-kms-v3d
gpu_mem=128
I tried to compile dkms. This broke with the following error message:
Code:
Error! Bad return status for module build on kernel: 4.4.36-v7+ (armv7l)

the file: Consult /var/lib/dkms/evdi/devel/module/build/make.log:
DKMS make.log for evdi-devel/module for kernel 4.4.36-v7+ (armv7l)
Fr 9. Dez 13:44:39 CET 2016
make KBUILD_VERBOSE=1 SUBDIRS=/var/lib/dkms/evdi/devel/module/build SRCROOT=/var/lib/dkms/evdi/devel/module/build CONFIG_MODULE_SIG= -C /lib/modules/4.4.36-v7+/build modules
make[1]: Entering directory '/home/pi/linux-c6d86f7aa554854b04614ebb4d394766081fb41f'
test -e include/generated/autoconf.h -a -e include/config/auto.conf || (                \
echo >&2;                                                       \
echo >&2 "  ERROR: Kernel configuration is invalid.";           \
echo >&2 "         include/generated/autoconf.h or include/config/auto.conf are missing.";\
echo >&2 "         Run 'make oldconfig && make prepare' on kernel src to fix it.";      \
echo >&2 ;                                                      \
/bin/false)
mkdir -p /var/lib/dkms/evdi/devel/module/build/.tmp_versions ; rm -f /var/lib/dkms/evdi/devel/module/build/.tmp_versions/*

  WARNING: Symbol version dump ./Module.symvers
           is missing; modules will have no dependencies and modversions.

make -f ./scripts/Makefile.build obj=/var/lib/dkms/evdi/devel/module/build
  gcc -Wp,-MD,/var/lib/dkms/evdi/devel/module/build/.evdi_drv.o.d  -nostdinc -isystem /usr/lib/gcc/arm-linux-gnueabihf/4.9/include -I./arch/arm/include -Iarch/arm/include/generated/uapi -Iarch/arm/include/generated  -Iinclude -I./arch/arm/include/uapi -Iarch/arm/include/generated/uapi -I./include/uapi -Iinclude/generated/uapi -include ./include/linux/kconfig.h -D__KERNEL__ -mlittle-endian -Iarch/arm/mach-bcm2709/include -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -Werror-implicit-function-declaration -Wno-format-security -std=gnu89 -fno-dwarf2-cfi-asm -fno-omit-frame-pointer -mapcs -mno-sched-prolog -fno-ipa-sra -mabi=aapcs-linux -mno-thumb-interwork -mfpu=vfp -funwind-tables -marm -D__LINUX_ARM_ARCH__=7 -march=armv7-a -msoft-float -Uarm -fno-delete-null-pointer-checks -Wno-maybe-uninitialized -O2 --param=allow-store-data-races=0 -Wframe-larger-than=1024 -fno-stack-protector -Wno-unused-but-set-variable -fno-omit-frame-pointer -fno-optimize-sibling-calls -fno-var-tracking-assignments -pg -Wdeclaration-after-statement -Wno-pointer-sign -fno-strict-overflow -fconserve-stack -Werror=implicit-int -Werror=strict-prototypes -Werror=date-time -DCC_HAVE_ASM_GOTO -Iinclude/drm  -DMODULE  -D"KBUILD_STR(s)=#s" -D"KBUILD_BASENAME=KBUILD_STR(evdi_drv)"  -D"KBUILD_MODNAME=KBUILD_STR(evdi)" -c -o /var/lib/dkms/evdi/devel/module/build/.tmp_evdi_drv.o /var/lib/dkms/evdi/devel/module/build/evdi_drv.c
In file included from include/asm-generic/int-ll64.h:10:0,
                 from ./arch/arm/include/asm/types.h:4,
                 from include/uapi/linux/types.h:4,
                 from include/linux/types.h:5,
                 from include/linux/list.h:4,
                 from include/linux/agp_backend.h:33,
                 from include/drm/drmP.h:35,
                 from /var/lib/dkms/evdi/devel/module/build/evdi_drv.c:10:
include/uapi/asm-generic/int-ll64.h:11:29: fatal error: asm/bitsperlong.h: No such file or directory
 #include <asm/bitsperlong.h>
                             ^
compilation terminated.
scripts/Makefile.build:258: recipe for target '/var/lib/dkms/evdi/devel/module/build/evdi_drv.o' failed
make[2]: *** [/var/lib/dkms/evdi/devel/module/build/evdi_drv.o] Error 1
Makefile:1401: recipe for target '_module_/var/lib/dkms/evdi/devel/module/build' failed
make[1]: *** [_module_/var/lib/dkms/evdi/devel/module/build] Error 2
make[1]: Leaving directory '/home/pi/linux-c6d86f7aa554854b04614ebb4d394766081fb41f'
Makefile:21: recipe for target 'all' failed
make: *** [all] Error 2
The same are with the evdi version 1.2.64, 1.2.65 and devel.
A try with the original installation package 'displaylink-driver-1.2.65.run*' end also with a similar error.

I've built the evdipp package without errors. so far so good

What steps have you done until to compile evdi and running the module?

Best regards
Michael
Mahdi2016 is offline   Reply With Quote