DisplayLink Forum

DisplayLink Forum (https://displaylink.org/forum/index.php)
-   Linux and Open Source (https://displaylink.org/forum/forumdisplay.php?f=29)
-   -   Dock/DisplayLink crashes repeatedly, Dell D6000, Ubuntu 20.04 (https://displaylink.org/forum/showthread.php?t=67314)

Brewhaus 09-02-2020 04:15 PM

Dock/DisplayLink crashes repeatedly, Dell D6000, Ubuntu 20.04
 
2 Attachment(s)
I am using a Dell D6000 which uses DisplayLink and running Ubuntu 20.04. I have installed the Ubuntu 20.04 'fix' but I believe that was for a different issue.

My dock crashes ~10-20 times every day. The monitors turn off and come back on a few seconds later but more annoyingly it does something to the audio on the system and it switches off my headset to the dell docking station audio (I am guessing because it appears to be newly connected?) so I have to go and change it back manually. This is really irritating, especially when I'm on a call when it happens as I have to interrupt whoever is talking to tell them I need them to repeat what they were saying. I had to connect my Ethernet cable directly to my laptop because my connection would drop every time this happened and it would kill my VPN which I would have to manually restart.

Every once in a while (it just happened while typing this thread) the dock freezes up completely and freezes my monitors and does not work again until I restart my machine. I noticed that when this happens /opt/displaylink/DisplayLinkManager is no longer running. I tried manually running it but that doesn't fix the problem.

The first attachment is from right after the dock crashes and restarts. The second is from when it crashed while I was typing this and has not recovered yet.

Please help, this is incredibly frustrating. Thank you.

Brewhaus 09-02-2020 04:26 PM

Additional issue
 
1 Attachment(s)
An additional issue I am having, though I'm not sure if it's a DisplayLink or Ubuntu issue is that along the right edge of my left most monitor there is about a half inch section that flickers the mouse pointer between the right edge of the left most monitor and the right edge of my middle monitor (both monitors that are connected through my DisplayLink dock). There is one specific column of pixels where the pointer actually shows up on both screens. I tried to take a screenshot of it but in the screenshot the pointer only showed up on the left most screen. I edited the photo to show what I see (pointer on both screens). When the pointer is on both screen or only on my middle screen, any actions still only affect the left most screen.

bambooloutre 09-04-2020 04:43 PM

Same here with a Gigabyte Aero 15X V8, ubuntu 20.04 and a Dell D8000.

Ubunutu 20.04 "performance patch" installed.

Random external screen "reboot" :(

TyVik 09-06-2020 09:55 AM

The same things with Dell XPS 15 and Ubuntu 20.04. It's very annoying!

Brewhaus 09-08-2020 05:44 PM

HDMI port?
 
I'm thinking it has to do with the HDMI port. I connected my HDMI directly to my laptop and I haven't had any problems since. Will update if the problem comes back.

Brewhaus 09-08-2020 05:49 PM

mouse problem
 
The mouse screen edge problem is also gone when I connected the HDMI cable directly to my laptop so it seems to be a DisplayLink problem as well.

TyVik 09-09-2020 07:24 AM

Possible solution
 
Hey! I used a solution with pulseaudio https://wiki.archlinux.org/index.php...ocking_station. It looks like still relevant for now. I've been working without crashes for 2 days.

mrpaulmanley 09-09-2020 05:23 PM

This solution seems to be working for me
 
Quote:

Originally Posted by TyVik (Post 90689)
Hey! I used a solution with pulseaudio https://wiki.archlinux.org/index.php...ocking_station. It looks like still relevant for now. I've been working without crashes for 2 days.

I can second this. I came specifically to mention that I had found a solution, but it seems it was already posted. Here's a link to another discussion here on the displaylink forums.
https://displaylink.org/forum/showpo...6&postcount=19

serf 09-15-2020 09:43 PM

Quote:

Originally Posted by Brewhaus (Post 90654)
An additional issue I am having, though I'm not sure if it's a DisplayLink or Ubuntu issue is that along the right edge of my left most monitor there is about a half inch section that flickers the mouse pointer between the right edge of the left most monitor and the right edge of my middle monitor (both monitors that are connected through my DisplayLink dock). ....

I had a similar problem. My workaround was to connect the middle monitor directly to the Dell 5500 with HDMI.


All times are GMT. The time now is 01:24 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.