DisplayLink Forum

DisplayLink Forum (https://displaylink.org/forum/index.php)
-   Linux and Open Source (https://displaylink.org/forum/forumdisplay.php?f=29)
-   -   Ubuntu 20.04 Software Update Killed Displaylink (https://displaylink.org/forum/showthread.php?t=67986)

leetuckert 11-09-2021 03:31 PM

Ubuntu 20.04 Software Update Killed Displaylink
 
So, being prompted this morning by Ubuntu 20.04, to do a software update, I stupidly agreed. It was of those that required a reboot. Upon reboot, my Displaylink device is completely broken. I removed the driver and reinstalled. No help. I removed the driver, downloaded the latest from Displaylink, installed it but, no help. The displaylink service shows up as dead. I can restart it and systemctl status shows that it is alive and running. However, lsusb does not show the evdi loaded. So, I am back to a single monitor. Anyone else having this problem today?

caitifty 11-17-2021 08:37 PM

Kernel update killed displaylink
 
Same problem - regular update updated kernel from 5.55.0-38 to 5.11.0-40 which stopped displaylink recognizing external monitors completely.

Only solution which worked was to force grub to load the previous kernel. Instructions for that here: https://www.systutorials.com/how-to-...-ubuntu-20-04/

pjones1063 11-19-2021 08:28 PM

Ubuntu 20.04 Software Update Killed Displaylink
 
I have the same issue. It wont run at all with 5.11.0-40. The installer actually fail with 5.11.0-40 running. Had to reinstall it with 5.55.0-38 running. Below is error in the kernel ring buffer - dmesg when 5.11.0-40 is up:


[ 30.391112] module: x86/modules: Skipping invalid relocation target, existing value is nonzero for type 1, loc 000000004e8c48c2, val ffffffffc14c3d80
[ 30.516312] module: x86/modules: Skipping invalid relocation target, existing value is nonzero for type 1, loc 000000009acc30c1, val ffffffffc14e1d80

Hope this gets corrected soon. Its a drag use in older kernel.

pjones1063 12-14-2021 01:49 AM

Bounce
 
I am sure others are having this issue on Ubuntu. No updates at all?

jefcap 12-18-2021 06:24 PM

DisplayLink is unstable in ubuntu 20.04 after kernel 5.11.0-38
 
1 Attachment(s)
Noticed the usb connection drop after ~1hr usage. I could collect the logs using DLSupportTool (https://synaptics.com/products/displ...x-support-tool).
Noticed the following errors in dmesg associated to usb connection:

[ 1473.657317] usb 2-1.1: Disable of device-initiated U1 failed.
[ 1473.668280] usb 2-1.1: Disable of device-initiated U2 failed.
[ 1473.668385] cdc_ncm 2-1.1:1.5 enx0c379621a317: unregister 'cdc_ncm' usb-0000:00:14.0-1.1, CDC NCM
[ 1473.723868] usb 2-1.1: Set SEL for device-initiated U1 failed.
[ 1473.730972] usb 2-1.1: Set SEL for device-initiated U2 failed.
[ 1474.065826] usb 2-1.1: reset SuperSpeed Gen 1 USB device number 7 using xhci_hcd
[ 1474.101742] usb 2-1.1: Warning! Unlikely big volume range (=767), cval->res is probably wrong.
[ 1474.101746] usb 2-1.1: [4] FU [Mic Capture Volume] ch = 2, val = -4592/7680/16
[ 1474.102340] usb 2-1.1: Warning! Unlikely big volume range (=672), cval->res is probably wrong.

Please verify the root cause of it. Full logs attached.

snipe122 12-20-2021 10:38 AM

Also experiencing connection drops, after some hours usage usually, connection is restored after some seconds.

Running 21.10 with latest updates (5.13.0-22-generic #22-Ubuntu SMP Fri Nov 5 13:21:36 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux).

I didn't upgrade / re-install Displaylink so I suspect some change in Kernel / some driver is causing this behavior. Having similar messages as @jefcap in the dmesg.

jefcap 03-18-2022 09:26 PM

up
 
Serious? No support since last year?

snipe122 03-21-2022 10:57 AM

I had a support ticket open and it was promised that a fix would be in 5.5 release. Unfortunately it's still an issue. I have replied back to the support but since that I did not hear anything positive.


All times are GMT. The time now is 05:08 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.