DisplayLink Forum

DisplayLink Forum (https://displaylink.org/forum/index.php)
-   Linux and Open Source (https://displaylink.org/forum/forumdisplay.php?f=29)
-   -   Very low performance with AMD Ryzen Pro 4750U (https://displaylink.org/forum/showthread.php?t=67580)

dominik.zogg 01-26-2021 04:12 PM

Very low performance with AMD Ryzen Pro 4750U
 
I bought a Club Dual 4k Dock (Displaylink):

I got to notebooks, one for work, one for private, both running Ubuntu 20.10
The first got a Intel® Core™ i7-10710U Processor and the dock works well.
The second got a AMD Ryzen Pro 4750U and the performance of the external sceens is very low.

Moving windows redraw that slow that it looks like wobbling, parts of the window are moved others aren't. Mouse cursor feels a bit more fluid, but far from usable.

Blafasel 01-29-2021 03:02 PM

Same Issue
 
I got exactly the same issue. Processor is a AMD Ryzen 4800H with integrated graphics (no dedicated graphic card).

When I connect a monitor directly to my Laptops HDMI Output, everything is great.

Via the docking station its basically unusable, even Youtube Videos have a lot of fragmentation going on while playing. It seems like the signal is separated into several horizontal blocks and they get updated one after the other with a noticable delay between each block.

ff801 04-16-2021 11:32 AM

same here. performance is really bad. basically this stuff is unusable.

irvis 04-19-2021 07:22 AM

Same here
 
Hey,
Sorry to write it, but same here.
Tried on Ubuntu 20.04 and 20.10.
Drivers version tried 5.3.1.34 and 5.4.0-55.153.
Laptop:
  • Processor: AMD® Ryzen 5 pro 4650u with radeon graphics × 12
  • Graphics: AMD® Renoir
System:
  • Gnome Version: 3.38.3
  • Kernel: Linux 5.8.0-50-generic x86_64
  • OS: Ubuntu 20.10

All works good, until I plug in docking station. Then system seems to behave like drunk old man. I get out of nowhere latency between click and run program, each window is fragmenting once moving, unusable, not able to work on that :(
as I recall on Ubuntu 18.04 and 18.10 it was ok. So I suspect drivers.

Do you think this can be connected with issue described here :confused:

spikerguy 04-21-2021 01:19 PM

Hello,

We're all in the same boat.
I have shared my device details Here

Why my situation is explained Here

I hope DisplayLink can atleast make use of GPU for Linux users.

Looking forward for a fix.

Manjaro Team.

MTrien 04-26-2021 02:05 PM

Same here
 
I have to same problem under Ryzen 5 3500u. The fix with the amdgpu drivers doesnt work here because the Radeon Vega Mobile Gfx is not supported. I had a problem with grafic glitches. Please fix these problems.

ff801 05-11-2021 05:19 AM

Are there any updates? Did your problems get fixed meanwhile?

Blafasel 05-17-2021 04:16 PM

Not for me. After digging thru tons of posts and googling for another day and waiting for any official response in this thread for a while, I gave up eventually and returned the docking station. Even if there is some way to fix it, I'm not buying a 200 Euro Docking Station in order to waste several days to set it up.

redgerat 05-26-2021 09:48 AM

Are there any updates for AMD only machines?

ff801 06-01-2021 07:11 AM

Updates
 
Waiting, waiting for ages now... any updates?

@Displaylink you could take at least an opinion or position to that topic and not just ignoring this bunch of poor users.

How about treating your users with some dignity?


All times are GMT. The time now is 11:41 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.