DisplayLink Forum

DisplayLink Forum (https://displaylink.org/forum/index.php)
-   Linux and Open Source (https://displaylink.org/forum/forumdisplay.php?f=29)
-   -   1 second lag (https://displaylink.org/forum/showthread.php?t=67229)

triplemaya 07-23-2020 06:48 PM

1 second lag
 
New install of ubuntu mate 20.04
installed displaylink with
displaylink-driver-5.3.1.34.run
install goes fine
Monitor is connected to docking station with displayport cable.

PROBLEM
key presses and mouse clicks take about one second to register. So the system is unusable.
Mouse movement is fine

This is only the case when the large monitor is set to primary and the laptop screen is off. When the system is running with two monitors there is no problem.
This configuration works perfectly when laptop is directly connected to large display with displayport cable.

Symptom present on three different docking stations, so not a hardware issue there.
All versions of hardware working perfectly in this configuration with ubuntu mate 18.04

billkoolguy 08-21-2020 10:26 PM

Bug Fix
 
There is a patch released to fix this on Ubuntu 20

https://github.com/DisplayLink/evdi/issues/181 thread of others with same issue

https://www.displaylink.org/forum/sh...ad.php?t=67148 patch link

I still need the patch for 18, so same problem for me needing to keep the primary display on.... :(

triplemaya 08-22-2020 08:20 AM

Hi Bill

Many thanks for this. A googled a lot but did not find the jan logged bug on github.

Works perfect now.

Very bad luck if you have the problem with 18. My 18.04 MATE installations run just fine.

Andrew

thopiekar 09-11-2020 05:30 PM

Quote:

Originally Posted by billkoolguy (Post 90604)
There is a patch released to fix this on Ubuntu 20

https://github.com/DisplayLink/evdi/issues/181 thread of others with same issue

https://www.displaylink.org/forum/sh...ad.php?t=67148 patch link

I still need the patch for 18, so same problem for me needing to keep the primary display on.... :(

Very useful. I'll look into this and see whether we can't make any use of the patch in an easy way :)

However, I'll only put focus on Ubuntu 20.04 (or whatever I run at the moment).

triplemaya 09-11-2020 06:47 PM

Works perfectly out of the box on 20.04

thopiekar 09-11-2020 07:22 PM

Quote:

Originally Posted by triplemaya (Post 90699)
Works perfectly out of the box on 20.04

You mean DisplayLink's patched package? I'm not sure how their changes influence other packages which are built from the same source. Nevertheless, I'll add it to my PPA next to the evdi packages.

triplemaya 09-12-2020 09:50 AM

I mean the XServer Patch

DisplayLink XServer Patch (20.04)

https://www.displaylink.com/downloads/file?d=310

And certain updates overwrite it so you have to do it again.

Zajic 09-14-2020 07:42 AM

I can't recommend this patch. After patch it caused xorg-server as very unstable and crashing for me (i have fresh install Linux Mint Mate). (https://gitlab.freedesktop.org/mesa/mesa/-/issues/3468) I only install last xorg-server from update center + my laptop display stayed as active.

After return back to lastest xorg-server it seems all fine. But yes, laptop display is still not fixed (https://gitlab.freedesktop.org/xorg/.../-/issues/1028). Keep your laptop display turned on. :rolleyes::(


I will wait for any proper displaylink version + xorg. It's a shame. :mad:


All times are GMT. The time now is 12:51 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.