DisplayLink Forum

DisplayLink Forum (https://displaylink.org/forum/index.php)
-   Linux and Open Source (https://displaylink.org/forum/forumdisplay.php?f=29)
-   -   Problem in Ubuntu 20.04 lts new install and wayland (https://displaylink.org/forum/showthread.php?t=67576)

bloodangel78 01-23-2021 11:07 PM

Problem in Ubuntu 20.04 lts new install and wayland
 
Hi,

I have a desktop with a nvidia card gtx 1070.
I have dell dock d3100
=> https://www.dell.com/en-us/work/shop...pc-accessories

My linux kernel is 5.8.0-40-generic

it work on my dell laptop installed some 1 or 2 years ago.


So I have installed the last driver

Code:

sudo ./displaylink-driver-5.3.1.34.run
I have connected one screen on my Nvidia gtx 1070 otherwise i have not the screen working, and second monitor on the dock.

1) In "Wayland", I see the second monitor in the display settings of Ubuntu, the second monitor on the dock work, but the screen stay black. Strangly I only see the mouse moving on it.

2) I have try "xorg" on the login screen, and on this mode it work correctly. So no problem with xorg.

Have you an idea what can be the problem with Wayland?

ps: I have install first the nvidia proprietary driver for my cart, but I have revert to open source drivers like asked in your doc.
And i have uninstall displaylink, reboot, then reinstall, but still the problem only for "wayland" so.

Thanks,

bloodangel78 01-27-2021 08:22 PM

So I have found the solution.

I need first to install the "display link" driver with ".sh" file, on wayland on Ubuntu, and with the open source driver installed for my graphic card Nvidia 1070.

And after reboot, I install back the nvidia official driver with
=> sudo apt-get install nvidia-driver-460

And now my second screen correctly display with the screen linked to the dock.

So problem fixed.


All times are GMT. The time now is 03:53 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.