DisplayLink Forum

DisplayLink Forum (https://displaylink.org/forum/index.php)
-   Linux and Open Source (https://displaylink.org/forum/forumdisplay.php?f=29)
-   -   Ubuntu 20.04 - Displays Not Working After Unplugging Dock (https://displaylink.org/forum/showthread.php?t=67874)

cwhite87 09-06-2021 11:42 AM

Ubuntu 20.04 - Displays Not Working After Unplugging Dock
 
Hello,

I am on Ubuntu 20.04, kernel 5.11.0-27 and using version 5.4 of the Display Link driver and EVDI 1.9.1. The first time I plug in the dock both of my monitors appear and everything works fine. A problem arises if I unplug (for example to use another computer with the dock) and then try to plug back in to the Ubuntu machine - nothing, blank screens. A restart fixes this.

I also unable to properly shut down the PC if using DisplayLink, the monitors go blank, but the fans and LEDs remain on, having to be turned off by holding the power button.

It always worked fine in the past, I could unplug the dock and plug it back in later, so I suspect it's a conflict with the kernel and driver versions, but does anyone have any ideas to sort it?

cwhite87 09-06-2021 02:51 PM

Update:

I installed kernel 5.8.18 from mainline and everything works as expected with driver 5.4 now. I was recently upgraded to 5.11 from 5.8 by the hardware enablement features. My hardware worked fine on 5.8, so I've just reinstalled it and made sure GRUB loads that kernel at start up and all works as expected.


All times are GMT. The time now is 11:43 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.