DisplayLink Forum

DisplayLink Forum (https://displaylink.org/forum/index.php)
-   Linux and Open Source (https://displaylink.org/forum/forumdisplay.php?f=29)
-   -   Ubuntu 18.04.1 LTS - DVI & HDMI 2k not working (https://displaylink.org/forum/showthread.php?t=66455)

rich-e-rich 01-25-2019 10:37 AM

Ubuntu 18.04.1 LTS - DVI & HDMI 2k not working
 
1 Attachment(s)
Hi There,

First off, thanks for taking the time to read this.

A note on my setup:
this docking station: https://plugable.com/products/ud-ultcdl
with this laptop: https://www.lenovo.com/gb/en/p/20L5C...e7&options_11= (note intel graphics card)
running Ubuntu 18.04.1 LTS - 100% up to date from the stand repositories

What happens:
I plug the usb-c into the power of my laptop everything is fine through the 4k HDMI adapter but the 2K adapter and the DVI adapter are not working at all. No monitors are detected when using these 2 adapters.

I've been advised by Plugable.com support: "The UD-ULTCDL utilizes DisplayLink drivers and internal chipsets to power the 2K HDMI and DVI port. The 4K HDMI connection and power delivery utilizes unique features of your USB-C port called Alt-Mode and Power Delivery. "

I've tried a few things already, including Plugable.com's own support script to install the latest DisplayLink drivers on a Debian based system, however this did not have any noticeable effect.

Attached is my output from your support tool.

Any advice greatly appreciated

rich-e-rich 02-04-2019 09:57 AM

it fixed itself?!
 
1 Attachment(s)
So after the original post, i pretty much gave up on the idea of having 2 hdmi monitors coming out of my dock. Several days have passed and literally nothing has changed to my knowledge.

I connected the dock as usual this morning, so i could use the hdmi 4k adapter, and i noticed that the audio options were listing a new output device: "Digital Output (S/PDIF) - Plugable UD-ULTCDL" & "Analogue Output.." -- this has happened once before, i'm sure. So i connected a second spare monitor from my office to the hdmi 2k adapter and it worked.

Voila, dual screen again...

I've attached another round of support tool output for anyone who has the knowledge or patience to cross reference them - i would love to know _what_ made the difference!

TLDR; something clicked today, as it started working without any new input from me. see file attached.

\_(ツ)_/


All times are GMT. The time now is 02:49 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.