DisplayLink Forum

DisplayLink Forum (https://displaylink.org/forum/index.php)
-   Linux and Open Source (https://displaylink.org/forum/forumdisplay.php?f=29)
-   -   DisplayLink connected screens turn black every few minutes after driver update (https://displaylink.org/forum/showthread.php?t=66358)

peda 11-12-2018 09:33 AM

DisplayLink connected screens turn black every few minutes after driver update
1 Attachment(s)
I've updated to DisplayLink Driver 4.4.24 and do regret it ... every few minutes (in most cases between 2 and 15 minutes, very rarely after 4 hours) the screens connected with DisplayLink turn black. In most cases it does help to unplug the DisplayLink USB-Connector and plug it back in again ... but sometimes I need to restart my computer ... super annoying.

I'm running Ubuntu 16.04 on a Dell Insiprion 5579 with a Dell Universal Dock D6000.

peda 11-12-2018 11:47 AM

I've just tried to upload another debug output right after the issue happened again, but I'm always getting the following error message:


Your submission could not be processed because a security token was missing.

If this occurred unexpectedly, please inform the administrator and describe the action you performed before you received this error.

Please let me know if there is another way I can send you this debug file

The other debug output can be downloaded here: http://ns342841.ip-37-187-167.eu/01.zip

mlukaszek 11-20-2018 07:08 AM


We are trying to reproduce the problem you're seeing, but so far without luck. An equivalent setup to yours has showed no sign of the problem in a soak test that was running over the weekend.

We do see our service being restarted in logs you sent, but it's unclear what caused it. Normally this could be caused by a device dropping off the USB bus, and reappearing again.

There are a few things you could do to help diagnosing it further.
  • It looks like evdi logs are surpressed on your system. Can you reenable them by using

    echo 5 > /sys/devices/evdi/loglevel
  • are there any updates on any of the screens when you see the issue, or are the screens idle when it happens?
  • it would be useful if you send us your xorg.conf - logs from X reveal quite a list of GPU drivers being loaded
  • can you try replugging the docking station to another USB port, without any downstream devices (just the dock and monitors), and see if it improves the situation?


peda 11-20-2018 07:15 AM

Thanks for looking into it

1) I'll definitely change the EVDI logging settings and upload another log file.
2) It also happens (sometimes) when the screen is in idle, but it does happen far more frequently when there are updates to the screen (i.e. switching through tabs in my IDE, looking at a photo gallery on a website, starting a youtube video, ...) and it does get far worse when I do attach a second monitor to the DisplayLink
3) Yes, will also send my xorg.conf with the next log
4) I'll try to to run the doch only with the monitors - on the laptop side I've already tried both USB 3.0 ports (without success) - I could only try the USB 2.0 port on the other side but I doubt this would be very successful?

peda 11-20-2018 10:13 AM

I did disconnect everything except the screen (and the network, because I don't have a USB/Network adapter at hand right now) from the DisplayLink device. The problem did occur again after less than 30 minutes (this time with 2 DisplayLink screens attached)

The process I followed was the following:
1) startup the computer ~11:30
2) run DLSupportTool --debug
3) change EVDI support tool
4) run DLSupportTool --debug ~11:38
5) screens did turn blank at ~12:02
6) did run DLSupportTool at ~12:03 (with the screens still blank - did not connect or disconnect any USB cables)

As the upload in the forum isn't working (maybe related to the size of the file) I've uploaded it to one of my servers: http://ns342841.ip-37-187-167.eu/02.zip

peda 11-20-2018 10:32 AM

I did now try it again, with the network cable disconnected and being connected to WiFi but the issue is still the same. For me it looks like something is wrong with the DisplayLink driver because

a) The light on my Dell D6000 does stay white/blue even when the screens are black


whereas it does turn red when the USB-cable is disconnected:


b) when there are other devices connected to my Dell D6000 they continue to work, even when the screens turn black

c) lsusb -t output doesn't change (when I compare the working state, with the state when the screens are black)

peda 11-20-2018 10:55 AM

1 Attachment(s)
Attached please also find my xorg.conf files

/etc/X11/xorg.conf.d/ is empty

attached are the contents of /usr/share/X11/xorg.conf.d/

Kamil 11-22-2018 10:32 AM


thank you for sending the logs. Unfortunately we were still not able to reproduce the issue when using same machine as you have.
One more thing worth checking can be update of device firmware. Can you please update the Firmware inside the device by using the Dell Utility https://www.dell.com/support/home/us...sal-dock-d6000 (Unfortunately it is Windows only) ?
We would like to understand the issue better, thus could you inform us which monitor is affected in case of single monitor setup and which port it is connected to?


peda 11-22-2018 10:49 AM

Hi Kamil,

thanks for your reply - it was working for me as well until I upgraded the DisplayLink drivers (to 4.4) - I've even tried going back to the old version (4.2) but it didn't help.

It doesn't matter to which port I connect the screen(s) - if only one is connected the issue does happen no matter on which of the two Display Ports it is connected to. If two screens are connected, they are both turning black at the same time, when the issue does occur.

As for the firmware update - I'll have to take the dock home with me - as we only have Macs and Linux computers in the office, but I do have a Windows PC at home where I could do the firmware upgrade - will probably be able to do that at the weekend and give you an update on Monday.

Is there anything strange in the logs? Unfortunately the DisplayLink logs are encrypted, so I can't look at them ...

peda 11-26-2018 08:16 AM

Hi Kamil,

I did try to do a firmware upgrade of the D6000 on one of my windows computers, but it told me that it already has the latest firmware installed. Are there any additional logs or increased logging outputs I could enable for you, to find the issue?

All times are GMT. The time now is 03:05 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.