DisplayLink Forum

DisplayLink Forum (https://displaylink.org/forum/index.php)
-   Linux and Open Source (https://displaylink.org/forum/forumdisplay.php?f=29)
-   -   1 out of 2 external displays lagging on Ubuntu 20.04 (https://displaylink.org/forum/showthread.php?t=67112)

Axodus 05-13-2020 08:19 PM

1 out of 2 external displays lagging on Ubuntu 20.04
 
1 Attachment(s)
Hey, I am running Ubuntu 20.04 and Windows 10 on my ThinkPad E595 (AMD Ryzen 5 3500U with AMD Radeon Vega 8 graphics). I have two external monitors plugged into it via the Toshiba Dynadock. On Windows 10 it works like a charm, but on Ubuntu 20.04, the monitor plugged into the Docking station is constantly lagging, but the monitor plugged into the laptop is fine.

Below are the files from the troubleshooting tool.

JakubDabrowski 05-15-2020 06:04 AM

Hello,

Thank you for contacting us on the forum.

Could you please tell me how extensive are the lags? Are they around 1s delay? If possible, could you record a video for us to see them?

As a possible solution, please try using Wayland and let me know if this has helped in any manner or the issue is exactly the same.

Thank you for your actions and feedback.

Best regards,
Jakub

alhae 05-19-2020 08:56 AM

Hello,

I am using a ThinkPad E595 with Ubuntu 20.04 as well (Ryzen 7 with Radeon RX Vega 10 Graphics) and experience the same issues. It is not only about lag but an extremely choppy and laggy image. The issue seems to be related to the Ryzen Processors and the EVDI Interface, as can be found here: https://github.com/DisplayLink/evdi/issues/164.

The link also includes a video that is an exact representation of my current experience.

I can confirm that the problem is the same when using Wayland, maybe a tiny bit better but still unusable.

I really hope this issue can be solved in the near future.

myersrj 05-25-2020 06:23 AM

Display Link Lag/Stutter with Ryzen
 
I have the same problem with my AMD Ryzen 5 3500U with AMD Radeon Vega 8 graphics. Problem is not an issue on Intel only Ryzen (tested same image against my Intel).

On Ubuntu 20.04 stuttering/tearing/lagging exists on both X Org and Wayland making it unusable.
This problem has existed for some time and I have seen it on 18.04, 19.04 and 19.10 when using the X Org drivers. When using the Wayland drivers on 19.04 the problem went away (The configuration I am using now).

The below link shows a picture of a laggy/tearing screen when you move a window from left to right. (I copied this from the website mentioned above)

https://user-images.githubuserconten...dca3019135.png

Given that the Laptop screen and HDMI port work fine I am assuming this is an issue with the Display link driver.

I am very keen to resolve this issue and am willing to promptly provide any information required to debug this. I am technically minded and have reasonable Linux skills.

Please let me know the next steps.

Regards Ralph.


All times are GMT. The time now is 06:27 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.