DisplayLink Forum

DisplayLink Forum (https://displaylink.org/forum/index.php)
-   Linux and Open Source (https://displaylink.org/forum/forumdisplay.php?f=29)
-   -   Install Fail: Missing Component: libdrm Ub 20.04 (https://displaylink.org/forum/showthread.php?t=67090)

Jeins 05-04-2020 01:52 PM

Install Fail: Missing Component: libdrm Ub 20.04
 
1 Attachment(s)
I tried to install the latest driver on Ubuntu 20.04. On installation I get the error: Missing Component libdrm. I reinstalled it manually and let the installer install it. Both didn't work for me. My diagnose files are attached.

txtweet 05-04-2020 02:40 PM

I have exactly the same error. I tried to install lipdrm-common and lipdrm2 and lipdrm-dev by my own but nothing changed.

Jeins 05-04-2020 02:55 PM

Good to know. Then I wait before new install of ubunut.

jarsal 05-04-2020 03:24 PM

Same here:
Quote:

Unsatisfied dependencies. Missing component: libdrm.
This is a fatal error, cannot install DisplayLink Linux Software.

pac421 05-04-2020 03:36 PM

I got the same problem on my side. I tried to reinstall manually the libdrm-dev package but installation always output :

Quote:

Unsatisfied dependencies. Missing component: libdrm.
I was moving from the non-official displaylink-debian driver to the official displaylink 5.3 driver after receiving the release mail so I also tried to reinstall the non-official displaylink-debian driver and got the same error.

DrPolucion 05-04-2020 05:59 PM

Same problem in a clean installation

txtweet 05-04-2020 08:22 PM

I have done some other tests.
I have the same problem on a clean install of 18.04 with Displaylink 5.3 but Displaylink 5.2 can be installed without trouble.

Libdrm-dev seems to have been updated very recently. I think this is the problem and that's why the driver can't be installed anymore on a clean install.

I can't suceed to install the previous version of the libdrm-dev package but maybe it can solve the problem.

JakubDabrowski 05-05-2020 09:52 AM

Dear users,

Thank you for your constant communication here on the forum.

We would like to apologize for the inconveniences that you have faced while trying to use our new driver.
We are aware of libdrm issue on our new driver for Ubuntu 20.04

Right now our Engineering Team is working on the resolution of the problem. We should be able to release a fix very shortly as our engineers are already testing the possible solution for this case.

As a possible temporary workaround you may start our installer in this manner:

$ LANG=C ./displaylink-installer-5.xxx.run where xxx is the installer version.
This should help you for now before we have a permanent fix done.

Thank you very much for your patience and I will be posting here any new information we would be able to share with you!

Kind regards,
Jakub

Stofe7 05-05-2020 11:57 AM

Thank you, but still issue:

sudo LANG=C ./displaylink-driver-5.3.0.28.run

Verifying archive integrity... 100% All good.
Uncompressing DisplayLink Linux Driver 5.3.0.28 100%
DisplayLink Linux Software 5.3.0.28 install script called:
Distribution discovered: Ubuntu 20.04 LTS

Installing

[ Installing EVDI ]
[[ Installing EVDI DKMS module ]]
Error! DKMS tree already contains: evdi-1.7.0
You cannot add the same module/version combo more than once.
EVDI DKMS module already installed.
[[ Installing module configuration files ]]
[[ Installing EVDI library ]]
cc -I../module -std=gnu99 -fPIC -c -o evdi_lib.o evdi_lib.c
In file included from evdi_lib.c:5:
/usr/lib/gcc/x86_64-linux-gnu/9/include/stdint.h:9:16: fatal error: stdint.h: No such file or directory
9 | # include_next <stdint.h>
| ^~~~~~~~~~
compilation terminated.
make: *** [<builtin>: evdi_lib.o] Error 1
ERROR: Failed to build evdi/5.3.0.28 library.

greghead 05-05-2020 03:44 PM

I had the same issue with the
Quote:

Unsatisfied dependencies. Missing component: libdrm.
Message. After using
Quote:

LANG=C ./displaylink-driver-5.3.0.28.run
it worked for me with 20.04 LTS fresh installation and latest updates installed.

I tried the older Firmware with 19.10 and it was really laggy. Not it's working pretty good. I'm happy with the performance and i hope it will keep that good :)


All times are GMT. The time now is 04:30 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.