DisplayLink Forum

DisplayLink Forum (https://displaylink.org/forum/index.php)
-   Linux and Open Source (https://displaylink.org/forum/forumdisplay.php?f=29)
-   -   Problem with HP dock and Ubuntu (https://displaylink.org/forum/showthread.php?t=66960)

lishak 01-23-2020 12:58 PM

Problem with HP dock and Ubuntu
Hello all,

I have a problem to run HP universal dock (USB-C) with my laptop in Ubuntu.

USBs and NIC works fine, but not Display outputs (2 displayPorts, I have two full HD monitors). Both full HD monitors are black and without signal from dock.

I installed display link driver 5.2.14 and also latest dkms. Installation was successfully done.

My PC:
HP ProBook 440 G6
Ubuntu 18.04.3 LTS (with latest updates)
Intel® Core™ i5-8265U CPU @ 1.60GHz × 8
HP universal dock USB-C (2UF95AA#ABB)

Can someone tell me please how to solve this problem?

Thank you in advance for your response.

deDamon 04-09-2020 09:48 PM

Good day! I have almost the same configuration. Have you solved your issue?
Thank you!

KatarzynaKowalczyk 04-14-2020 12:24 PM


To be able to determine the root cause for this behaviour and learn a bit more about your configuration I will need to take a look at the log files you can collect them by following steps In this article.

Thank you,

gregoireg 08-27-2020 08:22 AM

Similar problem here
1 Attachment(s)

I'm having the same trouble making HP universal dock to work with ubuntu 20.04.

Please find Support tool zip attached for equipment specs.

Have a good day !


entrop 12-25-2020 04:40 PM

1 Attachment(s)
Same here with dell latitude 7490 (latest bios) displaylink 5.3.1 and evdi, 1.9.0\1.7.2 (tried both). kernel is 5.10.2, dock is hp universal docking station usb c.

The driver is loaded:

[entrop@entrop-dellpc Downloads]$ lsmod | grep evdi
evdi 69632 0
drm_kms_helper 217088 3 udl,evdi,i915
drm 557056 9 udl,drm_kms_helper,evdi,i915
i2c_core 81920 11 i2c_designware_platform,videodev,i2c_hid,i2c_desig nware_core,drm_kms_helper,i2c_algo_bit,evdi,i2c_sm bus,i2c_i801,i915,drm
the only GPU active is intel

[entrop@entrop-dellpc Downloads]$ xrandr --listproviders
Providers: number : 1
Provider 0: id: 0x4a cap: 0xb, Source Output, Sink Output, Sink Offload crtcs: 4 outputs: 7 associated providers: 0 name:Intel
Screens aren't detected and are al black (two dell displays)

[entrop@entrop-dellpc Downloads]$ ls -l /sys/devices/platform/evdi*
/bin/ls: cannot access '/sys/devices/platform/evdi*': No such file or directory

All times are GMT. The time now is 04:37 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.